2015-05-02

Mark Rotteveel escribió:

 

JayBird 2.2. actualmente soporta Java 5 y más recientes. Cuando planeé Jaybird 2.3 (ahora 3.0), estaba planeando el continuar con soporte a Java 6 con Jaybird 3.0 y eliminar el soporte con Jaybird 3.1. Sin embargo decidí cambiar de decisión.

 

Java 5 ha tenido la finalización de actualizaciones desde octubre de 2009, y Java 6 también lo ha hecho desde febrero de 2013. Java 7 también tuvo su fin de actualizaciones en este mes de Abril 2015. Revisen la política de fin de vida de productos Oracle Java en: http://www.oracle.com/technetwork/java/eol-135779.html.

Con esto en mente, he tenido la decisión de realizar los cambios siguientes:

Empezando con Jaybird 2.2.8, Jaybird 2.2 ya no soportará Java 5 y solo liberaré versiones para Java 7 y Java 8 (mantendré compatibilidad con Java 6 fara la rama 2.2, de tal manera que las personas puedan compilar su propia versión si lo requieren).

Jaybird 3.0 no soportará Java 6 para el momento en que planeo soportar Java 7 y 8 (tal vez 9). Dependiendo de la fecha de la liberación de Jaybird 3.0, el soporte a Java 7 podría ser eliminado.

 

(fuente)

Java Componentes 

Navegación